Difference between revisions of "Minimum system requirements for GEOS-Chem"

From Geos-chem
Jump to: navigation, search
m (Do I need to install any libraries for GEOS-Chem?)
(Do I need to install any libraries for GEOS-Chem?)
Line 84: Line 84:
  
 
However, for those of you who will be working with the "raw" GEOS-Chem met field data, or with the various satellite data products, then you will probably want to install the  
 
However, for those of you who will be working with the "raw" GEOS-Chem met field data, or with the various satellite data products, then you will probably want to install the  
GEOS-Chem_programming_resources#HDF and HDF-EOS|HDF and HDF-EOS libraries]] so that you can write Fortran code to read and process these data.   
+
[[GEOS-Chem_programming_resources#HDF and HDF-EOS|HDF and HDF-EOS libraries]] so that you can write Fortran code to read and process these data.   
  
 
Here is a table that describes the file formats that are used by the various data products:
 
Here is a table that describes the file formats that are used by the various data products:

Revision as of 13:46, 28 March 2008

Several GEOS-Chem users have asked "What type of machine do I need to buy in order to run GEOS-Chem?" Here are our suggestions.

Hardware Recommendations

Our hardware recommendations are:

  • Enough memory to run GEOS-Chem
    • At least 2 GB RAM
    • But more than 4 GB RAM for running at 2x2.5
    • You may want to consider 8 GB RAM if you plan on doing any of the following:
      • Running high-resolution (e.g. 1 x 1) global GEOS-Chem simulations
      • Running high-resolution (e.g. 1 x 1, 0.5 x 0.667) nested-grid GEOS-Chem simulations
      • Running 2 x 2.5 global GEOS-Chem simulation and saving a lot of output fields (the more output you generate the more memory GEOS-Chem will require)
  • Sufficient disk storage for met fields.

The Linux flavor (RedHat, SuSE, Fedora, Ubuntu, etc.) is not important. Also, 64-bit architecture is not an issue with GEOS-Chem.

Can GEOS-Chem run on Microsoft Windows (XP, Vista, etc.)?

No. You will need to run GEOS-Chem in a Unix or Linux environment.

However, GEOS-Chem should be able to run in Mac OS Leopard, which is 100% compatible with Unix. As of Mar 2007, we are not aware of anyone having done this yet.

Which compilers does GEOS-Chem support?

At present GEOS-Chem supports the following compilers:

Compiler Platform(s)
SGI MipsPro compiler SGI Origin
SGI Power Challenge
Intel Fortran compiler (IFORT) (versions 9, 10) SGI Altix Itanium
Linux machines
Sun X4100/Linux
Portland Group International (PGI) Linux machines
SunStudio Fortran compiler (versions 11, 12) Sun X4100/Solaris
Sun X4100/Linux
IBM AIX compiler Older IBM machines

For Linux, we strongly recommend to use the Intel Fortran (IFORT) compiler. In our experience, we have found that the Intel compiler is just a better all-around compiler than PGI. We have had various minor compatibility problems with PGI. Also, the Intel compiler is available at relatively low cost to you if you work for an educational institution.

The latest version of Intel (10.x) is very optimized for multi-core chipsets.

Parallelization

Also, you should be aware that because GEOS-Chem uses OpenMP parallelization, you can only run on as many nodes as are shared by the memory. For example, if you had 2 PC's, and each PC w/ 4 cores each, then you can only run on 1 PC at a time (i.e. 4 cores). This is because OpenMP has a requirement that all of the processors on the machine must be able to see all of the memory on the machine. In that case, you could run 2 jobs simultaneously on 4 cores, but not a single job on 8 cores. See www.openmp.org for more information.

MPI (Message Passing Interface) is required for passing memory from one physical system to another. The current version of GEOS-Chem does not yet have this capability.

How much disk space will I need for GEOS-Chem?

It will depend on which type of met data (GEOS-4 or GEOS-5) that you will use, and how many years of data you will download. Typical disk space requirements are:

Data type Size
GEOS-4 4x5 met (uncompressed) ~13 GB/yr
GEOS-4 2x25 met (uncompressed) = ~52 GB/yr
GEOS-5 4x5 met (uncompressed) ~30 GB/yr
GEOS-5 2x25 met (uncompressed) = ~120 GB/yr

Do I need to install any libraries for GEOS-Chem?

At present, it is not necessary to have any external libraries (such as HDF-EOS, netCDF, etc.) installed to use GEOS-Chem. All you need is one of the supported [#Which compilers does GEOS-Chem support?|Fortran compilers listed above]] and a Unix environment.

However, for those of you who will be working with the "raw" GEOS-Chem met field data, or with the various satellite data products, then you will probably want to install the HDF and HDF-EOS libraries so that you can write Fortran code to read and process these data.

Here is a table that describes the file formats that are used by the various data products:

Data type File format used
GEOS-4 met HDF4-EOS
GEOS-5 met HDF4-EOS
MOPITT satellite data HDF4-EOS
AIRS satellite data HDF4-EOS
OMI satellite data HDF5-EOS

NOTES:

  • HDF4 is an older version of HDF. HDF5 is the newer version.
    • One of the major differences is that with HDF4 the file size may not exceed 2GB. This restriction has been lifted in HDF5.
  • HDF-EOS is a "superset" of HDF that was developed by NASA and others to create extra data structures (Grid, Point, and Swath) that are more relevant for earth science applications.
    • HDF4-EOS is HDF-EOS that is based on HDF4.
    • HDF5-EOS is HDF-EOS that is based on HDF5.
  • You must first install HDF4 before installing HDF4-EOS.
    • HDF4 requires that ZLIB, JPEG, (and optionally, SZLIB) libraries must also be installed.
  • You must first install HDF5 before installing HDF5-EOS
    • HDF5 requires that ZLIB, JPEG, (and optionally, SZLIB) libraries must also be installed.

Also, it may be a good idea to install the latest version of the netCDF library, because you may receive data files from people in other institutions which are in this format.

It is also possible to read HDF, HDF-EOS, and netCDF files into IDL with the GAMAP package. See the GAMAP User's Guide for more information.